www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: apache 2.0 patch to force proxy to speak HTTP/1.0
Date Tue, 15 May 2001 22:47:48 GMT
Ian Holsman wrote:

> so do you think I should apply the pacth,
> 
> or should I add a 'disable-keepalive' patch which just put a 'connection:close' instead
> of the connection:... (as well as the http/1.0)

The trouble is that the patch breaks the proxy as is - because it does
not follow the HTTP/1.0 spec at all apart from sending an HTTP/1.0
instead of HTTP/1.1.

In addition, we should not be breaking proxy to fix other broken 3rd
party software. The patch is only temporarily needed anyway, because the
bug in Weblogic will be fixed soon, and the need for the patch will fall
away. This kind of patch should be added to the contributed patches for
v2.0 so that it is available should a workaround be necessary.

Regards,
Graham
-- 
-----------------------------------------
minfrin@sharp.fm		"There's a moon
					over Bourbon Street
						tonight..."
Mime
View raw message