www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Fritsch <nfrit...@enition.com>
Subject Doesn't work with threads (apache 2) ?
Date Thu, 13 Dec 2001 11:11:31 GMT
Hi!

I tried to use mod_proxy with Apache 2 (2.0.28) and the worker MPM on
FreeBSD 4.4, but it doesn't work. I saw a post on a list that said that
it doesn't work with several processes, but should with a single
process. I tried with only one worker process; doesn't work either. The
proxy always blocks in apr_sockaddr_info_get (DNS query), but I couldn't
figure why.

Does anyone know how to make it work?

mod_proxy works better with the prefork model and without threads. But I
still have a problem with HTTP 1.1 clients. It seems that "sometimes",
the proxy forgets to put two "\n" between the headers and the body ; it
only puts one, and adds one at the very beginning.... The result being
that the browser interprets that as simple text-file. This doesn't occur
with HTTP 1.0 clients.
Did anyone have the same problem before ?

Thanks

Nicolas Fritsch






Mime
View raw message