www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bloom <...@covalent.net>
Subject Re: Doesn't work with threads (apache 2) ?
Date Thu, 13 Dec 2001 16:20:50 GMT
On Thursday 13 December 2001 03:11 am, Nicolas Fritsch wrote:


Apache 2.0 does not support threads on FreeBSD.  In order for it to
work, you would need to be on the absolute latest version of FreeBSD,
and you would need to run in -X mode.  The bottom line is that until
FreeBSD fixes their threading, don't try this.

Ryan

> Hi!
>
> I tried to use mod_proxy with Apache 2 (2.0.28) and the worker MPM on
> FreeBSD 4.4, but it doesn't work. I saw a post on a list that said that
> it doesn't work with several processes, but should with a single
> process. I tried with only one worker process; doesn't work either. The
> proxy always blocks in apr_sockaddr_info_get (DNS query), but I couldn't
> figure why.
>
> Does anyone know how to make it work?
>
> mod_proxy works better with the prefork model and without threads. But I
> still have a problem with HTTP 1.1 clients. It seems that "sometimes",
> the proxy forgets to put two "\n" between the headers and the body ; it
> only puts one, and adds one at the very beginning.... The result being
> that the browser interprets that as simple text-file. This doesn't occur
> with HTTP 1.0 clients.
> Did anyone have the same problem before ?
>
> Thanks
>
> Nicolas Fritsch

-- 

______________________________________________________________
Ryan Bloom				rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------

Mime
View raw message