www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Petucci" <michael.petu...@smedia.com>
Subject question
Date Fri, 14 Dec 2001 18:48:08 GMT
Hi,

Sorry to bother you, but I found you on the mod_gzip newsgroup and I wanted to send you a
quick question. I hope you can help me.

I'am running an apache 1.3.22 with mod_gzip 1.3.9a, mod_ssl and php 4.0.6, and works perfectly
for a couple of hours. Then I get several messages in my error_logs like:

[Fri Dec 14 07:16:59 2001] [error] [client 211.7.175.4] Client sent malformed Host header
[Fri Dec 14 07:17:35 2001] [error] mod_gzip: EMPTY FILE [/tmp/gzip/_5324_909_810.wrk] in sendfile2
[Fri Dec 14 07:17:35 2001] [error] mod_gzip: Make sure all named directories exist and have
the correct permissions.
[Fri Dec 14 07:17:36 2001] [error] mod_gzip: EMPTY FILE [/tmp/gzip/_5322_942_843.wrk] in sendfile2
[Fri Dec 14 07:17:36 2001] [error] mod_gzip: Make sure all named directories exist and have
the correct permissions.
[Fri Dec 14 07:20:25 2001] [error] mod_gzip: EMPTY FILE [/tmp/gzip/_5323_918_819.wrk] in sendfile2

And too many clients told me that they can't saw some pages. The only way to make it work
again for a couple of hours is restarting the apache. What is more strange is when I restart
the apache I get in my errors_log:

[Fri Dec 14 07:53:44 2001] [warn] child process 5325 did not exit, sending another SIGHUP
[Fri Dec 14 07:53:44 2001] [warn] child process 5333 did not exit, sending another SIGHUP
[Fri Dec 14 07:53:44 2001] [warn] child process 5337 did not exit, sending another SIGHUP
[Fri Dec 14 07:53:46 2001] [warn] child process 5326 still did not exit, sending a SIGTERM
[Fri Dec 14 07:53:46 2001] [warn] child process 5327 still did not exit, sending a SIGTERM
[Fri Dec 14 07:53:46 2001] [warn] child process 5333 still did not exit, sending a SIGTERM
[Fri Dec 14 07:53:50 2001] [error] child process 5327 still did not exit, sending a SIGKILL
[Fri Dec 14 07:53:50 2001] [error] child process 5333 still did not exit, sending a SIGKILL

My mod_gzip configuration is:

<IfModule mod_gzip.c>
   MOD_GZIP configuration
   mod_gzip_on Yes
   mod_gzip_minimum_file_size  1002
   mod_gzip_maximum_file_size  0
   mod_gzip_maximum_inmem_size 60000
   mod_gzip_item_include mime "application/x-httpd-php"
   mod_gzip_item_include mime text/*
   mod_gzip_item_include mime "httpd/unix-directory"
   mod_gzip_dechunk Yes
   mod_gzip_temp_dir "/tmp/gzip"
   mod_gzip_keep_workfiles No

   mod_gzip_item_include file "\.php$"
   mod_gzip_item_include file "\.txt$"
   mod_gzip_item_include file "\.htm$"
   mod_gzip_item_include file "\.html$"

   mod_gzip_item_exclude file "\.css$"
   mod_gzip_item_exclude file "\.wml$"
   mod_gzip_item_exclude file "\.js$"
</IfModule>

Can you help me in realize what is going on?

thanks in advance,
Michael Petucci




Mime
View raw message