www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.D. Silvester" <jsil...@uwo.ca>
Subject mod_proxy and HTTP 302 response
Date Fri, 16 Aug 2002 05:34:08 GMT

I am running Apache 1.3.26 with mod_proxy and am having a interesting
problem.  A specific site that I connect to with the proxy server is
doing a redirect on requests.  However, the redirect is not being
interpreted properly by the proxy server.  If I connect to the same
site without using the proxy server, my browser is properly redirected,
which is why I am unable to figure out exactly what is happening.

If I make a request of http://www.someserver.com/webpage.html  it is
supposed to be redirected to http://server1.someserver.com/webpage.html

When using the proxy server I get this in my web browser:

Date: Fri, 16 Aug 2002 05:17:28 GMT Server: RealPage 2700
Set-Cookie: RealPageID=590675136; expires=Tue, 31-Dec-2002 00:00:00 GMT; 
path=/; domain=.someserver.com Location:
http://server1.someserver.com/webpage.html Content-Type: text/html
X-Cache: MISS from xxx.xxx.xxx.xxx Connection: close 


And I see this in the log file

yyy.yyy.yyy.yyy - - [16/Aug/2002:01:17:40 -0400] "GET http://www.someserver.com/webpage.html
HTTP/1.1" 302 179


Any ideas what is happening here?  As I said, if I connect directly to the
web site without the proxy server in the middle, the redirect works and
the correct page is displayed.  Also, the web site is not mine and is
outside of my control.


John


Mime
View raw message