www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier DECKMYN <odeckmyn.l...@teaser.fr>
Subject mod_proxy + mod_ssl + StdEnvVars
Date Thu, 17 Apr 2003 15:02:02 GMT
Hi there !

I'm playing with apache 1.3.27 with mod_ssl 2.8.x

I have an ssl virtual host on 443. This VH uses mod_proxy with a proxy
set as a rewriterule.

Here is my config :

<VirtualHost customer.mydomain.com:443>
    ServerAdmin webmaster@mydomain.com
    ServerName customer.mydomain.com

    ErrorLog logs/error.Apache
    CustomLog logs/access.customer.mydomain.com combined

    RewriteEngine on
    RewriteCond %{REQUEST_URI} !^/static/
    RewriteCond %{HTTP:Authorization}  ^(.*)
    RewriteRule ^(.*) http://obelix.mydomain.com:8080/VirtualHostBase/https/customer.mydomain.com:443/customer/website/VirtualHostRoot/$1
[P]

    SSLEngine on
    SSLCertificateFile /isp/web/conf/ssl.crt/mydomain.com.crt
    SSLCertificateKeyFile /isp/web/conf/ssl.key/mydomain.com.key
  
    SSLOptions +StdEnvVars

    SetEnvIf User-Agent ".*MSIE.*" \
           nokeepalive ssl-unclean-shutdown

</VirtualHost>

(in fact, the proxy is used to serve a Zope server).

Using, SSLOptions +StdEnvVars, and connecting to a test web page, I
expect to get SSL_* and HTTPS_* variables set into REQUEST object.

But this won't work :( I get nothing else more than without
"SSLOptions +StdEnvVars". It looks like setting "SSLOptions
+StdEnvVars" does nothing :(

If I remove Proxy and serve a local PHP page, I get the correct SSL_*
and HTTPS_* variable into REQUEST (seen with a phpinfo() test)

Another test : Adding "ProxyVia On" sets correct HTTP_VIA variable
into REQUEST !

So my question is : how can I get both mod_proxy and mod_ssl work
together ? How can i get the HTTPS_* variables set into REQUEST ?

ps : using ProxyPass and ProxyPassReverse statement instead of
RewriteRule do the same.

Thanx for your support.



Mime
View raw message