www-modproxy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabiano Felix <fe...@getnet.com.br>
Subject Re: Proxy "Open Relay" used to send messages - Apache2
Date Thu, 31 Jul 2003 19:11:13 GMT
Hello All,

I found the solution: the parameter "ProxyRequest" is enabled, but isn't
necessary (this is causing the problem, since it's permit the use of
proxy as a relay)...

Thanks and regards,

Fabiano Felix

Em Qui, 2003-07-31 às 11:37, Fabiano Felix escreveu:
> Hello All,
> 
> I'm having problems with "Open HTTP Proxy" Relay. Some spammers are
> using my proxy to send messages with other mail servers (my proxy is
> "trusted" for this mail servers). After tests, I concludes that the
> method used for this is a connection by "http-post" (tested with
> pxytest.pl (http://www.unicom.com/sw/pxytest)). If I block "http-post",
> probably my proxy will not function. Someone has this problem? How to
> solve this.
> My proxy configuration (it's an Apache2):
> "
> <VirtualHost 10.1.144.3:80>
>         ServerName msexchange.xxxxxxx.com.br
>         UseCanonicalName On
>         ProxyVia On
>         ProxyRequests On
>         ProxyPass / http://10.2.144.4/
>         ProxyPassReverse / http://10.2.144.4/
>         ProxyPreserveHost On
>         ProxyPass /exchange/ http://10.2.144.4/exchange/
>         ProxyPassReverse /exchange/ http://10.2.144.4/exchange/
>         ProxyPass /exchweb/ http://10.2.144.4/exchweb/
>         ProxyPassReverse /exchweb/ http://10.2.144.4/exchweb/
> </VirtualHost>
> "
> 
> Regards,
> 
> Fabiano Felix


Mime
View raw message