www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [Nexus] Upload of pom and jars without using Maven to re-create them
Date Wed, 09 Mar 2011 15:18:46 GMT
On 9 March 2011 14:34, Brian Demers <bdemers@sonatype.com> wrote:
> Come to find out we ran out of disk.  I'll setup some monitoring (like
> a good admin) so we don't run into this problem again.
> If anyone is still seeing any problems please let me know.


If possible, maybe Nexus could report this to the user.

-1 as the error number is not very helpful!

Also, ideally Nexus should not hang when uploading if it runs out of
space - it should fail with a suitable error.
I'll update the JIRA issue I filed.

> On Tue, Mar 8, 2011 at 4:04 PM, sebb <sebbaz@gmail.com> wrote:
>> I want to upload the commons-daemon 1.0.5 jars from the binary
>> release, as the Maven files were not uploaded at the time.
>> I extracted the jars (binary, source, javadoc) and pom, createdt the
>> associated hashes and sigs, and I'd now like to upload them to a
>> staging directory.
>> However Nexus does not seem to make this easy or even possible.
>> I tried creating a bundle using repository:bundle-pack (having first
>> copied the files to my local repo), however Nexus appears to have hung
>> trying to upload the bundle. The blue uploading bar is still going
>> after about 5 minutes.
>> Previously I tried uploading individual artifacts but that was not successful.
>> It does not help that the artifacts window is so small that one can
>> only see about 3 lines without scrolling.
>> But it's also no clear whether one has to upload hashes or not, and I
>> kept getting messages about duplicate artifacts and incorrect MD5 and
>> sigs.
>> Has anyone successfully uploaded ?

View raw message