xerces-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mukul Gandhi <muk...@apache.org>
Subject Re: Xerces Parsing Error
Date Thu, 21 Jun 2018 06:53:43 GMT
On Wed, Jun 20, 2018 at 9:11 AM, Garvit Sharma <garvits45@gmail.com> wrote:

> I am facing issues while parsing Hadoop config file. I might because of
> the older version of Xerces.
>
> How to include xerces newer version in the classpath?
>
> 2018-06-18 19:27:55,324 FATAL org.apache.hadoop.conf.Configuration
>                   - error parsing conf core-default.xml
>
> javax.xml.parsers.ParserConfigurationException: Feature '
> http://apache.org/xml/features/xinclude' is not recognized.
>
> at org.apache.xerces.jaxp.DocumentBuilderFactoryImpl.newDocumentBuilder(Unknown
> Source)
>

 I'm not an expert in Hadoop. But I'll try to answer this question from a
fundamental perspective.

You can download the latest version of Xerces, and place its jars in the
folder "jre\lib\endorsed" and Hadoop might pick it from there. This would
work prior to JDK 1.9. With JDK 1.9 and above, simply placing the new
Xerces jars in the system classpath shall work. Starting from JDK 1.9,
the jre\lib\endorsed
method has been removed from the JDK.





-- 
Regards,
Mukul Gandhi

Mime
View raw message