xerces-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Dillard <David.Dill...@veritas.com>
Subject RE: [EXTERNAL] Re: java project build question, in eclipse IDE
Date Mon, 30 Jul 2018 13:27:27 GMT
That sounds like a good idea.  Testing on JDK 1.4, which has been EOL for years now, seems
like a waste of time.

Java 6 extended support ends this December, so either Java 6 or Java 7 might be a good place
to start.


From: Mukul Gandhi [mailto:mukulg@apache.org]
Sent: Monday, July 30, 2018 7:13 AM
To: Elliotte Rusty Harold <elharo@ibiblio.org>
Cc: j-dev@xerces.apache.org; j-users@xerces.apache.org
Subject: [EXTERNAL] Re: java project build question, in eclipse IDE

On Mon, Jul 30, 2018 at 4:25 PM, Elliotte Rusty Harold <elharo@ibiblio.org<mailto:elharo@ibiblio.org>>
wrote:
I'm curious. Why do you need 1.4 and 1.3? Do you have customers using those?

This needs to be understood correctly. Xerces can run on min JREs 1.4 (if XSD 1.1 is needed)
and 1.3 respectively. This doesn't mean, that Xerces cannot run on higher version JREs (I've
personally tested, that Xerces 2.12.0 can run fine up to JDK 9).

May be its time, we need to revisit the min JDK levels for Xerces. Michael Glavassevich needs
to organize consensus on this.



--
Regards,
Mukul Gandhi
Mime
View raw message