xerces-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elliotte Rusty Harold <elh...@ibiblio.org>
Subject Re: java project build question, in eclipse IDE
Date Mon, 30 Jul 2018 10:55:29 GMT
"I'm member of Xerces dev team. To develop for XSD 1.1 we need JDK
1.4, and to develop for trunk we need JDK 1.3."

I'm curious. Why do you need 1.4 and 1.3? Do you have customers using those?



On Mon, Jul 30, 2018 at 2:06 AM, Mukul Gandhi <mukulg@apache.org> wrote:
> On Sun, Jul 29, 2018 at 3:56 PM, Elliotte Rusty Harold <elharo@ibiblio.org>
> wrote:
>>
>> Is there a reason you're still using 1.4.2?
>
>
> I'm member of Xerces dev team. To develop for XSD 1.1 we need JDK 1.4, and
> to develop for trunk we need JDK 1.3.
>
>>
>> That's likely your issue.
>> javax.xml.validation.SchemaFactory wasn't added to the JDK until 1.5.
>
>
>  You're right, and this solves my problem. When I provided explicitly the
> dependency xml-apis.jar (from XSD 1.1 branch's tools folder) to my project
> that was giving error, it worked.
> But I think, the problem I mentioned is likely an Eclipse IDE problem (I'm
> using the 2014 edition). I had given the XSD 1.1 project as a dependency to
> my own project, and this should have provided xml-apis.jar to my own
> project.
>
> Thanks for your help.
>
>
>
> --
> Regards,
> Mukul Gandhi



-- 
Elliotte Rusty Harold
elharo@ibiblio.org

---------------------------------------------------------------------
To unsubscribe, e-mail: j-users-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-users-help@xerces.apache.org


Mime
View raw message