xml-xindice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "FTL Africa" <f...@mutare.icon.co.zw>
Subject Re: XUpdate - runtime error
Date Thu, 19 Jun 2003 15:01:06 GMT
Hi Tom,

Thanks for the help.
I am still getting the same error message thuogh.
I did make the change to XObjectImpl.java and set the JAVA_HOME variable in
build.bat. However I am still getting the same error mesage.

What could be wrong?

I have set the ANT_HOME variable to %JAVA_HOME%\lib is this OK?

TIA

Amos

----- Original Message -----
From: Tom Sugden <tom@epcc.ed.ac.uk>
To: <xindice-users@xml.apache.org>
Sent: Thursday, June 19, 2003 11:19 AM
Subject: RE: XUpdate - runtime error


> Hi,
>
> This is a known problem with XUpdate and Java 1.4.1. In my experience the
> endorsed directory fix can be problematic, so it's better to fix the
problem
> in the source code and rebuild Xindice. Here are instructions, based on a
> link that someone else posted a while back:
>
> Edit the file:
>
>   <XINDICE_HOME>\java\src\org\apache\xindice\core\xupdate\XObjectImpl.java
>
> Change the code at line 105
>
>   from: return (NodeList) _xobj.nodeset();
>   to:   return (NodeList) _xobj.nodelist();
>
> Recompile the Xindice source code:
>
>   From your Xindice home directory, run the 'build.bat' (assuming you have
> set the JAVA_HOME environment within the batch file). This will create the
> Xindice.jar again in the lib folder.
>
> Hope this helps.
>
> Bye,
> Tom
>
> -----Original Message-----
> From: FTL Africa [mailto:ftla@mutare.icon.co.zw]
> Sent: Wednesday, June 18, 2003 3:51 PM
> To: xindice-users@xml.apache.org
> Subject: XUpdate - runtime error
>
>
> Hi,
>
> I have installed Xindice 1.0. I am working on a project that requires
Tomcat
> 1.4.1, Apache
> 1.3.7, java 1.4.1 and xindice 1.0.
>
> I have set the following environment variables on WIN2000. (Note: I did
the
> "endorsed" folder thing)
>
> PATH
> C:\xml-xindice-1.0\bin;
> C:\j2sdk1.4.1_01\bin
>
> XINDICE_HOME
> C:\xml-xindice-1.0
>
> XINDICE_LIB
> C:\xml-xindice-1.0\java\lib
>
> CLASSPATH
> .;
> C:\j2sdk1.4.1_01\lib\tools.jar;
> %XINDICE_LIB%\xmldb.jar;
> %XINDICE_LIB%\xindice.jar;
> %XINDICE_LIB%\openorb-1.2.0.jar;
> %XINDICE_LIB%\xerces1.4.3.jar;
> %XINDICE_LIB%\xalan-2.0.1.jar;
> %XINDICE_LIB%\openorb_tools-1.2.0.jar;
> %XINDICE_LIB%\xml-apis-1.0.jar;
> %XINDICE_LIB%\xmldb-sdk.jar;
> %XINDICE_LIB%\xmldb-xupdate.jar;
> C:\ProgramFiles\ApacheGroup\Tomcat4.1\common\lib\servlet.jar;
> -Djava.endorsed.dirs=%XINDICE_LIB%\endorsed
>
> CATALINA_HOME
> C:\ProgramFiles\ApacheGroup\Tomcat4.1
>
> At the moment I am working on examples in the Developer's guide and they
all
> worked perfectly except for one.
>
> 1. I am getting the following error message on running (it compiles OK)
the
> XUpdate example:
>     org.apache.xindice.client.corba.db.APIException:
>
> IDL:org/apache/xindice/client/corba/db/APIException:1.0
>         at org.apache.xindice.client.corba.db.APIExceptionHelper.
>  read(APIExceptionHelper.java:112)
>         at org.apache.xindice.client.corba.db._CollectionStub.
>  queryCollection(_CollectionStub.java:833)
>         at
> org.apache.xindice.client.xmldb.services.XUpdateQueryServiceImpl.update
>  Result(XUpdateQueryServiceImpl.java:165)
>         at
org.apache.xindice.client.xmldb.services.XUpdateQueryServiceImpl.
>  update(XUpdateQueryServiceImpl.java:185)
>         at org.apache.xindice.examples.XUpdate.main(XUpdate.java:91)
>         XML:DB Exception occured 1 Query Processing Error
>
> 2. Another problem I have is that "javac" cannot see the classpath (At
least
> I think so). The
>     classpath is being echoed on the command-line but I have to include
> the -classpath argument and specify
>     the jar files for javac to recognize the classes. Isn't that weird?
>
> Can anyone help me with the problems I mentioned?
>
>
> Thanks In Advance,
>
> Amos Makumbe
>
>
>
>
>
>



Mime
View raw message