xml-xindice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Pietschmann" <Stefan.Pietschm...@inf.tu-dresden.de>
Subject Re: xindice 1.1b2 + cocoon 2.1 + tomcat 4.1.27 + winxp - HOW??
Date Mon, 08 Sep 2003 17:22:27 GMT
at first thanx alot for your help. it didn't help too much tough :(

I guess what i need would be a step by step explanation on how to set up xindice so far, that
I'm able to add collections and try stuff out. I'll just tell you how far I've come... most
likely I've made some stupid mistake:

1) got xindice from cvs
2) built war file
3) put *.war into tomcat/webapps (& started tomcat) --> which built the xindice-1.1b2
directory
4) created new external folder "xindice" with those files I got from the cvs (and building):
    bin/*; dist/*, java/lib/*, config/*
4.5) set this folder as variable %XINDICE_HOME%
5) I changed the path to the database in config/system.xml to
     <root-collection dbroot="D:/apache_group/tomcat/webapps/xindice-1.1b2/WEB-INF/db/"
name="db" use-metadata="on">
    which is where the database is the deployed webapp
6) added %XINDICE_HOME%\bin to the %PATH% variable

7) now, when I start tomcat, I can access the "ugly debug tool" with http://localhost:8080/xindice-1.1b2
and I can also browse the db if I follow the link, but how do I use the command line tool?

in the %XINDICE_HOME% folder the xindice command doesn't work at all, if I switch the bin/
directory, with " xindice lc -c" i get an error message saying that the command "java" is
either written wrong or doesn't exist :/

thanx again
stefan

p.s.: I just want to try it out... but I'm not even as far as that :( :(


----- Original Message ----- 
  From: Barzilai Spinak 
  To: xindice-users@xml.apache.org 
  Sent: Monday, September 08, 2003 3:52 PM
  Subject: Re: xindice 1.1b2 + cocoon 2.1 + tomcat 4.1.27 + winxp - HOW??


  Stefan, I wrote that HowTo for Xindice 1.1b but I guess it should be updated for 1.1b2,
which, among other changes, now
  tries to connect to port 8888 of localhost by default.
  I don't know if your problems are related to this. I have recently installed Xindice 1.1b2
and Cocoon 2.1 and have them working 
  under Tomcat 4.1.18. For a quick fix to this I added another instance of a Coyote Connector
under port 8888. This is done
  in $TOMCAT_HOME/conf/server.xml
  You can also use a command line option for specifying the url as xmldb:xindice://host:port/db
  or something like that.
  I don't remember now.

  Other things that have changed, the servlet name went from "Xindice" to "xindice", but I
think you can configure that when you build
  the sources.

  The database part.  Under $XINDICE_HOME/conf  there's a file called server.xml
  In that file you can specify the db collection, with an absolute path, or a relative one
(relative from the conf  directory).
  Remember to use slashes '/' and not blackslashes '\' even if you are under windoze!


  Ok, I have to go now. Tell me if this has solved some of your problems or not.

  BarZ

  under 
  Stefan Pietschmann wrote:

    hi,

    i'm totally new to xindice and I'm trying to set it up together with my cocoon installation.

    cocoon is installed correctly and worked. I downloaded xindice successfully from CVS,
built the *.war and deployed it. when I start tomcat I get the message "INFO: Database successfuly
started" - so i guess xindice is running as expected. I can also read the "UGLY DEBUG TOOL"
thing and browser the database.

    now, for being able to work with it, i would like to install the command line tool. however,
i haven't found any useful (or detailed enough) information on how to install it on win xp.
    I did everything explained at http://nagoya.apache.org/wiki/apachewiki.cgi?HowToXindice1o1bCocoon2
(the "Installing the Xindice command line tool" part).
    I have a separate xindice folder outside of the webapps, (set to %XINDICE_HOME%), added
%XINDICE_HOME%/bin to the %PATH% variable ... well. that's it.
    if I only have bin/* , dist/*, java/lib/* and config*/ folders in there (as suggested)
the "xindice" command doesn't work at all. If I copy the build folder in as well it at least
gives me two action options: "start" and "debug".

    but how do i tell the xindice command line tool in the external %XINDICE_HOME% folder
to use the database in %TOMCAT_HOME%/webapps/xindice-1.1b2/WEB_INF/db ?? the given command
there doesn't work - most likely since it's explained for linux.

    well, sorry if that's newbie stuff ;) if i got anything wrong please correct me. any help
is very much appreciated!!

    thanx guys
    stefan


Mime
View raw message