xml-xindice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Alford <dalf...@appraisalforum.com>
Subject Re: Problem selecting attribute
Date Tue, 03 Feb 2004 22:22:48 GMT
Vadim,
    I made a mistake in my first post. Rather than selecting an 
attribute, I want to select on an attribute, so I can find some xml node 
with the required attribute and value.

I only downloaded 1.0 as it was labelled stable on the apache site. I 
tend to avoid trying beta software when assessing a product for a 
project. If 1.1 is stable (ish) I will download it.

Dan

Vadim Gritsenko wrote:

> Dan Alford wrote:
>
>> Hi All,
>>    Im trying to evaluate Xindice for an upcoming project but I have 
>> ran into a problem. I cant seem to select an individual attribute.
>
>
>
> Are you sure that you want to select an attribute?
>
>
>> xindice xpath -c /db/test -q //*[@number]
>
>
>
> This will select elements which has attribute named 'number'
>
>
>> xindice xpath -c /db/test -q //*[@number="1"]
>
>
>
> And this also will select elements, whose 'number' attribute has value 
> '1'.
>
>
>> Xindice 1.0 (Birthday)
>
>
>
> Dan, I'm not actually sure wether anybody here will be able to help 
> you with 1.0. Most of the folks are moved to 1.1
> (and if there are 1.0 users here - they will correct me ;-)
>
>
> Vadim
>
>
>

-- 
Dan Alford
Java Developer
Appraisal Forum
6800 Poplar Avenue, Ste. 121
Memphis, TN 38138
866-367-8611 Ext.290
Direct 901-759-2475
dalford@appraisalforum.com
www.appraisalforum.com
 



Mime
View raw message