xml-xindice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Melhuish <j.melhu...@signal.qinetiq.com>
Subject Re: Xindice 1.0 -> 1.1 upgrade problem
Date Wed, 21 Apr 2004 16:53:45 GMT
Vadim Gritsenko wrote:

> Jonathan Melhuish wrote:
>
>> "Could not locate Xindice driver class! Ensure the necessary jars are 
>> on your classpath: xindice.jar, xmldb.jar, xmldb-sdk.jar is a good 
>> guess"
>
>
> Add to your JSP:
>
>  <%= new org.apache.xindice.client.xmldb.embed.DatabaseImpl() %>
>
> If it fails you'll know that classpath is the problem. You have to 
> have xindice-*.jar and all xmldb-*.jar's in WEB-INF/lib of your webapp.

Thanks, that was indeed the problem.  I didn't realise that, even if 
you've already installed the WAR, you still have to:

*  Download and extract the source tarball
*  Run "build"
*  Copy the resulting xindice.jar from "dist" to the webapp's "lib" 
directory

I don't quite understand why this is necessary.

I think the current migration notes on the Wiki are a little confusing 
if you are trying to install a release version (from a WAR file, for 
example).  Should I write a "migrating to a stable 1.1 release" how-to?

Cheers,

Jon

Mime
View raw message