xml-xindice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Devine, Arthur W" <devi...@spawar.navy.mil>
Subject RE: Xindice 1.0 -> 1.1 upgrade problem
Date Tue, 20 Apr 2004 17:12:41 GMT
Please remove me from the mailing list.  
I no longer want to receive e-mail from the zindice-users group.


-----Original Message-----
From: Vadim Gritsenko [mailto:vadim@reverycodes.com]
Sent: Tuesday, April 20, 2004 12:23 PM
To: xindice-users@xml.apache.org
Subject: Re: Xindice 1.0 -> 1.1 upgrade problem


Jonathan Melhuish wrote:

> I've changed the driver references to 
> "org.apache.xindice.client.xmldb.embed.DatabaseImpl", as per the 
> upgrade notes on the Wiki:
>
> http://wiki.apache.org/xindice/UpgradeTo11EmbedNotes
>
> However, I get the following error when trying to run a JSP page (on 
> Tomcat) that tries to access the database:
>
> "Could not locate Xindice driver class! Ensure the necessary jars are 
> on your classpath: xindice.jar, xmldb.jar, xmldb-sdk.jar is a good guess"
>
> Aha, I think, that's because the JAR files in the project's 
> "WEB-INF/lib" directory are still those for 1.0, not for 1.1.  So I 
> replace them with the contents of the "WEB-INF/lib" directory of the 
> xindice directory (unpacked from a WAR), but to no avail.  I also 
> tried copying the JARs from a Xindice 1.1 source tarball, but with the 
> same error.
>
> Any ideas, anyone?


Add to your JSP:

  <%= new org.apache.xindice.client.xmldb.embed.DatabaseImpl() %>

If it fails you'll know that classpath is the problem. You have to have 
xindice-*.jar and all xmldb-*.jar's in WEB-INF/lib of your webapp.

Vadim

Mime
View raw message