xml-xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim McLaughlin <me_at_dog...@yahoo.com>
Subject Problems referencing *$Factory.class in jar files
Date Thu, 01 Jul 2004 17:22:58 GMT
I have a document with I am trying to create and it
works fine inside my eclipse environment, but when I
create a jar file and try to run my application, I am
having problems with my class file references:

in code:
RRDocument RRDoc = RRDocument.Factory.newInstance();

I get error when running java application from 

java -cp xmltypes.jar;. -jar my.jar param1

Exception in thread "main"
java.lang.NoClassDefFoundError:
org/blah/foo/RRDocument$Factory

This seems to be a reference to the static factory
class inside the generated code (src from scomp).

Do I need to do something for the static factory class
in the MANIFEST.MF file?

If so, I currently have tried:
Name: org/blah/foo/RRDocument/Factory.class

and tried 

Name: org/blah/foo/RRDocument.Factory.class

and also tried the base xmltypes.jar with no
modifications. 

Any help is appreciated.


		
__________________________________
Do you Yahoo!?
Yahoo! Mail - You care about security. So do we.
http://promotions.yahoo.com/new_mail

- ---------------------------------------------------------------------
To unsubscribe, e-mail:   xmlbeans-user-unsubscribe@xml.apache.org
For additional commands, e-mail: xmlbeans-user-help@xml.apache.org
Apache XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/


Mime
View raw message