xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Bielk" <andreas.bi...@codesense.com>
Subject <text> and stroke-opacity
Date Wed, 10 Oct 2001 21:22:34 GMT
Hi all!

I can´t figure out if this is a bug in Adobe´s viewer (3.0b),
or if it is a SVG problem; and if it is a SVG problem, why
does it work in Batik?

The following renders (transcodes) correctly i Batik, but not in AV3:

<?xml version="1.0" encoding="iso-8859-1"?>
<svg width="500" height="200" xmlns="http://www.w3.org/2000/svg">
  <g>
    <text x="70"
          y="120"
          stroke-opacity="0.3"
          stroke="black"
          fill-opacity="0.3"
          fill="#909090"
          font-weight="bold"
          font-size="50"
          text-anchor="start" >
      Test
    </text>
  </g>
</svg>

(The "stroked" text appears at 0,0 but the "filled" text at 70,120)

If I remove stroke-opacity="0.3" it works! Any ideas, anyone?

/Andreas Bielk

/**********************************************************
                  C o d e S e n s e  A B
       Marinens väg 30, SE-136 40 Haninge, Sweden
Office: +46 (0)8 - 707 32 30  GSM: +46 (0)70 - 532 92 01
                 http://www.codesense.com
***********************************************************/
    (PGP public key available at: search.keyserver.net)


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message