xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Becker <pe...@peterbecker.de>
Subject More JDK1.4 issues (JPG transcoding)
Date Fri, 05 Apr 2002 10:52:02 GMT
Hello,

I still have troubles with the combination of Batik 1.1.1 and JDK 1.4. 
This time I don't get any useful JPEG out of this:

<svg width="120" height="30">
  <rect fill="rgb(255,255,255)" x="0" y="0" width="120" height="30"/>
  <path d="M1 -2 L1 32" 
style="stroke-width:2;stroke-opacity:1;stroke:rgb(0,0,0);fill-opacity:0;fill:rgb(0,0,0);opacity:1"

/>
  <text id="xweb" 
style="font-family:Marlett;font-size:14;stroke-width:0;stroke-opacity:1;stroke:rgb(0,0,0);fill-opacity:1;fill:rgb(0,0,0);opacity:1"

x="8" y="16">Welcome</text>
  <path d="M1 23 L7 23 L1 30" 
style="stroke-width:0;stroke-opacity:1;stroke:rgb(0,0,0);fill-opacity:1;fill:rgb(0,0,0);opacity:1"

/>
</svg>

The result when transcoding this into JPEG with 1.4 seems to be an empty 
white box. Rendering PNGs works fine, rendering JPEGs with JDK 1.3.1, 
too. System is SuSE Linux 7.3.

Any ideas what's going wrong?

   Peter


PS: I gave up on the color problem, it seems impossible to get PNGs 
using exactly the specified color in the vicinity of filter effects in 
all viewers. Esp. Internet Explorer and Konqueror have problems, while 
some other viewers don't. I assume it is related to some advanced PNG 
features ignored by some viewers.


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message