xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Peeters" <stefan.peet...@arkos.be>
Subject SVGDocument cache
Date Mon, 09 Sep 2002 12:08:04 GMT
Hi,

The loading of an svg document takes a bit of time, so I implemented a
cache which keeps track of SVGDocument instances...
So far so good

But when I run the following piece of code.

BufferedImageTranscoder t = new BufferedImageTranscoder(Color.white, trans,
ratio);
SVGDocument layerDoc = <old> or <new> instance of SVGDocument
System.out.println("layerDoc : "+layerDoc);
System.out.println("layerDoc nextsibling: "+layerDoc.getPreviousSibling());
System.out.printl("layerDocgetDocumentElement: "+layerDoc.getDocumentElement
());
TranscoderInput input = new TranscoderInput(layerDoc);
displaylayer();

The layer is displayed the first time, or every time when a new instance of
SVGDocument is created.
When I try to do this routine with an instance of an SVGDocument which was
already used in this routine.
 This results in the same output in the console window. But the layer which
should be visible isn't visible?

Does anyone have an idea why?

By the way in batik 1.1.1 it doesn't display at all...

Txs in advance,

Stefan Peeters.



---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message