xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Beech <JBe...@dmu.ac.uk>
Subject RE: Newbie Question
Date Thu, 24 Apr 2003 11:00:32 GMT
Solved it. Thanks anyway.

-----Original Message-----
From: Steve Beech 
Sent: 24 April 2003 11:45
To: 'batik-users@xml.apache.org'
Subject: Newbie Question


Hi,

I'm trying to get Batik working with a Servlet but get the following error: 

java.lang.NoClassDefFoundError: org/apache/batik/util/XMLResourceDescriptor 
at org.apache.fop.svg.SVGElementMapping.setupSVG(SVGElementMapping.java:30) 
at
org.apache.fop.svg.SVGElementMapping.addToBuilder(SVGElementMapping.java:92)

at org.apache.fop.apps.Driver.addElementMapping(Driver.java:398) 
at org.apache.fop.apps.Driver.addElementMapping(Driver.java:409) 
at org.apache.fop.apps.Driver.setupDefaultMappings(Driver.java:273) 
at org.apache.fop.apps.Driver.(Driver.java:181) 

I've copied the batik.jar file to my WEB-INF/lib folder but this doesn't
help. I also tried copying the batik lib folder here too to ensure all of
the other batik-jar files were available.

Can anybody tell me where I'm going wrong?

Thanks,

Steve

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message