xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas DeWeese <Thomas.DeWe...@Kodak.com>
Subject Re: "Broken Image" in Image-Element
Date Tue, 26 Oct 2004 09:24:58 GMT
Hi Urs,

Urs Reupke wrote:

>>> Instead of showing the default "image not found"-icon, the SVG-Canvas 
>>> displays an image just the size I indicated in the referencing tag:
>>
>>    Displays an image of what?
> 
> Uh...shouldn't write mails that late :)
> It displays an "broken image" image.
> What makes me wonder is that the images seem to be found ("Broken Image"
> instead of default "image not found" icon, but not displayed.

    I think there is only one broken image icon that we use in
all cases that we can't find/decode the image.  However if you
have it displayed in a JSVGCanvas we set the title and desc on the
little 'i' in a circle, in the lower right hand corner to be a
short summary of why we couldn't load the image, this should popup
in a tooltip if the document has any dynamic behavior turned on.

    If that doesn't work or isn't particularly useful (it
usually isn't) I would start adding prints to the Batik source.

>>    What happens if you switch back?
> 
> I already tried - there is no change. [...]

    Then I'm guessing this is a red-herring.

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message