xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas DeWeese <Thomas.DeWe...@Kodak.com>
Subject Re: svg image in a svg file
Date Fri, 11 Feb 2005 00:48:20 GMT
Hi Chandra,

    I suspect that your absolute file url is at fault.
My first suggestion would be to make it a relative
URL.  If the base SVG is in for example:
	"C:\tacplanner\image"
you could use just:
	"icons/special/0_SITE.svg"

    This has many advantages like if you move it to a
server just the way you reference the base document
changes (assuming you keep the same structure on the
server).

    If you want to keep using the absolute Url
I would suggest reformatting it as:

	file:///C:/tacplanner/images/icons/specia/0_SITE.svg

    Note, use forward slash '/' not backward slash '\', also
use three (yes three) forward slashes to indicate the start
of the directory path.

Chandra Srinivasan wrote:

> 	<image x="722.5283" y="599.1704" width="15" 
> height="15" 
> xlink:href="file:/C:\tacplanner\images\icons\special\0_SITE.s
> vg"/> 

> but on opening the same using JSVGCanvas it doesn't work (I 
> just get a red square box). How do i fix this?
> 
> Thanks in advance for your help.
> 
> Chandra Srinivasan
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: batik-users-help@xml.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message