xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lila Tran <chinaros...@gmail.com>
Subject Problems embed svg in ie
Date Tue, 23 Aug 2005 21:22:12 GMT
I wrote a jsp page to embed svg graphics in ie, and it just looks
awfully weird, however, when I try to svg in firefox and konqueror, it
looks just fine.  I'm not sure how to explain this exactly, but here
is a snip of the code that I use to embed svg in a browser.

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
<%@ taglib uri="http://myfaces.apache.org/extensions" prefix="x"%>

<h:panelGrid columns="1" border="0" cellpadding="3" cellspacing="3"
width="95%" align="center">
  <h:panelGrid columns="1" border="0" cellpadding="5" cellspacing="0"
styleClass="home">
    <f:facet name="header">
      <h:outputText value="#{messages['home.intro']}" />
    </f:facet>
    <x:panelTabbedPane width="100%" activeTabStyleClass="column15"
inactiveTabStyleClass="column15">
   
      <x:panelTab id="alertByType"
label="#{messages['dashboard.tab.AlertsByType']}">
        <f:subview id="alrtsByType">
          <f:verbatim><object data="jfree/alertByType.svg"
width="600px" height="400px"/></f:verbatim>
        </f:subview>
      </x:panelTab>
            
    </x:panelTabbedPane>
  </h:panelGrid>
</h:panelGrid>

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message