xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted.Clem...@apcc.com
Subject Re: RMI: getElementByID returns null
Date Fri, 12 Aug 2005 18:02:36 GMT
Thomas,

>> Thomas.DeWeese@Kodak.com wrote:
>> Ted.Clement@apcc.com wrote:
>> > We recently migrated from Batik 1.5 to v1.6 and noticed that the
>> > SVGDocument.getElementById() method
>> > was broken.  We are using RMI to stream the SVGDocument from a server
to
>> > one (or more) clients.

>>   Did this actually work in 1.5?  I was under the impression that
>> lots of things would break...

All the parts of the API that we are using work just fine on the client(s)
after
serilization using Batik v1.5 ( create/search/modify SVGDocument & GVTTRee
operations)
When we get closer to release, I'll make sure you get an opportunity to see
what
we're done (-if, of course, you're interested!)

>> > A little research showed that the elementsByID  list is marked
"transient"
>> > in the AbstractDocument:
>> > [...]
>> > I was wondering what the reason was for marking this component
"transient"

>>    Mostly a copy/paste error from elementsByTagName etc.  Do you want
>> to provide a patch and a test (not using RMI, just Serialization)
>> so this doesn't break again in the future?

I can take a look into it next week.
What exactly do you want for a "patch" ?
Do you mean a binary patch?  ...software patch ?
What kind of "test"?


Thanks,
Ted


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message