xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cameron McCormack <cam-batik-us...@aka.mcc.id.au>
Subject Re: Compilation problems while installing batik source codes: a lot of "Class must implement the inherited abstract method..."
Date Thu, 12 Jan 2006 00:02:40 GMT
Hi Eric.

Eric Yuan:
> I am really getting mad these 2 whole days installing batik sources. i
> first used Eclipse to import all files (including ".classpath"
> unchanged) under the downloaded directory "xml-batik", and got about
> 1900 error messages, most of which are "Class must implement the
> inherited abstract method Node.setTextContent(String)"... from
> packages "org.apache.batik.dom", "org.apache.batik.dom.svg" and so on.

This sounds like you are compiling an old version of the sources that
doesn't implement the DOM 3 methods without using the '-source 1.4'
command line option to the JDK 1.5 compiler.  You need this because JDK
1.5 includes the DOM 3 interfaces and older versions of Batik only
implement the DOM 2 interfaces.

I suggest downloading a more recent copy of the sources (if this is in
fact the problem), such as this:

  http://svn.apache.org/builds/xml-batik/batik-src-06-01-10.zip

or checking out the sources from the SVN repository:

  http://xml.apache.org/batik/svn.html

Cameron

-- 
 Cameron McCormack			ICQ: 26955922
 cam (at) mcc.id.au			MSN: cam (at) mcc.id.au
 http://mcc.id.au/			JBR: heycam (at) jabber.org

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message