xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hinst <...@exobitnetworks.com>
Subject RE: Problem rasterizing image element
Date Mon, 18 Sep 2006 19:17:03 GMT
Thomas,

I tried the code from svn, and now I get the following error message:

file:/mnt/nfs/home/ipi/ipi.exobitnetworks.com/www/test/notworking.svg:0
The URI
"file:/mnt/nfs/home/ipi/ipi.exobitnetworks.com/www/test/displayArt.php?id=39
"
on element <image> can't be opened because:
JDK URL is corrupt or unsupported variant
        at
org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(Unknown Source)
        at
org.apache.batik.transcoder.image.ImageTranscoder.transcode(Unknown Source)
        at
org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(Unknown Source)
        at
org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(Unknown Source)
        at org.apache.batik.apps.rasterizer.SVGConverter.transcode(Unknown
Source)
        at org.apache.batik.apps.rasterizer.SVGConverter.execute(Unknown
Source)
        at org.apache.batik.apps.rasterizer.Main.execute(Unknown Source)
        at org.apache.batik.apps.rasterizer.Main.main(Unknown Source)
... error (SVGConverter.error.while.rasterizing.file)


I am using version 1.5.0_08 of the Sun JDK for Linux. That should work fine
with Batik, shouldn't it?

Thanks,
Rob
 

-----Original Message-----
From: thomas.deweese@kodak.com [mailto:thomas.deweese@kodak.com] 
Sent: Sunday, September 17, 2006 12:31 PM
To: batik-users@xmlgraphics.apache.org
Cc: batik-users@xmlgraphics.apache.org; Rob Hinst
Subject: RE: Problem rasterizing image element

Hi Rob,

Rob Hinst <rob@hinst.net> wrote on 09/17/2006 12:22:32 PM:

> Here is a copy of the Tux image: 
> http://hinst.net/~rhinst/images/Tux.jpg
> 
> I'll check out the SVN version and see if that gives me any clues.

    The current SVN version worked fine for me with JDK 1.5 (on Windows).

    Good luck!

> > I've got some svg documents that make use of the <image /> tag to
> display
> > external raster images. The raster images display fine in the SVG
> document,
> > so I know I've got the SVG correct. When I run the documents through 
> > the batik rasterizer, in place of the image there is a stock icon of 
> > a
> broken
> > image. Does the rasterizer support the image element? 
> 
>    Yes, the rasterizer definitely supports the image element.
> 
> > java -jar batik-rasterizer.jar -m "image/jpeg" -q 0.99 -d "test.jpg"
> > "test.svg"
> 
>    To be clear if you use:
>         java -jar batik-squiggle.jar "test.svg"
>    It displays fine?
> 
> > And here is my SVG document:
> 
>    I don't see anything wrong here.
> 
> > <image xlink:href="Tux.jpg" x="10" y="10" width="50" height="50"/>
> 
>    Any possibility of seeing (a small version of) "Tux.jpg"?
>    Also have you tried any other images?
> 
> > I've used both an absolute URL and a relative URL for the image, 
> > because
> I
> > heard that could cause issues, but it hasn't seemed to have any 
> > impact

> > either way.
> 
>    This strikes me as very odd.  You might try upgrading to the SVN
version
> just because that version should print out why it can't read the 
> raster image...
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: 
> batik-users-help@xmlgraphics.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: 
> batik-users-help@xmlgraphics.apache.org
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message