xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cameron McCormack <...@mcc.id.au>
Subject Re: flowText extension / svg version compatibility
Date Fri, 08 Sep 2006 08:57:10 GMT
Hi Stephen.

Stephen Drake:
> I have noticed that the Batik flowText extension sometimes clashes with svg
> 1.2.  Before I get too far I should mention that this isn't actually a
> problem for me right now.  I am using svg 1.2 for the multiImage feature,
> but I prefer flowText over flowRoot for the moment because I want to do
> vertical alignment.  When this is organised so that the multiImage elements
> occur in separate documents that are referenced with an image element, it
> all works nicely.  However, I'm curious as to whether the flowText extension
> is meant to work with svg 1.2 and whether it is already deprecated in favour
> of flowRoot.

It seems a bug was introduced in the XBL support (which is only for 1.2
documents), where extension elements wouldn’t have their proper DOM
elements created (which results in the ClassCastException).  This is
fixed in SVN now.

Cameron

-- 
Cameron McCormack, http://mcc.id.au/
	xmpp:heycam@jabber.org  ▪  ICQ 26955922  ▪  MSN cam@mcc.id.au

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message