xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thomas.dewe...@kodak.com
Subject Re: Problem rasterizing image element
Date Sun, 17 Sep 2006 16:04:41 GMT
Rob Hinst <rob@hinst.net> wrote on 09/16/2006 11:41:25 AM:

> Hi,
> 
> I've got some svg documents that make use of the <image /> tag to 
display
> external raster images. The raster images display fine in the SVG 
document,
> so I know I've got the SVG correct. When I run the documents through the
> batik rasterizer, in place of the image there is a stock icon of a 
broken
> image. Does the rasterizer support the image element? 

   Yes, the rasterizer definitely supports the image element.

> java -jar batik-rasterizer.jar -m "image/jpeg" -q 0.99 -d "test.jpg"
> "test.svg"

   To be clear if you use:
        java -jar batik-squiggle.jar "test.svg"
   It displays fine?

> And here is my SVG document:

   I don't see anything wrong here.

> <image xlink:href="Tux.jpg" x="10" y="10" width="50" height="50"/>

   Any possibility of seeing (a small version of) "Tux.jpg"?
   Also have you tried any other images?

> I've used both an absolute URL and a relative URL for the image, because 
I
> heard that could cause issues, but it hasn't seemed to have any impact
> either way.

   This strikes me as very odd.  You might try upgrading to the SVN 
version
just because that version should print out why it can't read the
raster image...


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message