xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Constantine <mac...@lecture123.com>
Subject Re: NullPointerException after batik update
Date Thu, 01 Mar 2007 08:55:29 GMT
A little info which might be helpful:

1) Using a plain canvas, I scribbled, then went to another plain canvas,
no problem (forward movement seems to work ok). (slide1.svg)
2) I then revisited the slide. Still no problem. (slide1.svg)
3) The second I start to scribble on that slide, those NPEs come rolling
across the console. The saved slide is slide3.svg

Let me know if you need more info. Thanks.

Martin.



Martin Constantine wrote:
> Rats!! Pre-mature rejoicing is never a good thing. Sorry. I was able to
> get past navigating the first slides, then I revisited the slides and
> saw a repeat of the symptoms. Here's the exception:
>
> java.lang.NullPointerException
>         at
> org.apache.batik.anim.AnimationEngine.tick(AnimationEngine.java:347)
>         at
> org.apache.batik.bridge.SVGAnimationEngine.access$600(SVGAnimationEngine.java:98) 
>
>         at
> org.apache.batik.bridge.SVGAnimationEngine$AnimationTickRunnable.run(SVGAnimationEngine.java:844)

>
>         at 
> org.apache.batik.util.RunnableQueue.run(RunnableQueue.java:237)
>         at java.lang.Thread.run(Thread.java:595)
>
> Once again, this seems to repeat endlessly until I end the session (I
> didn't try to see if it ended when I scribbled). I tried Attaching the 
> documents before and after I noticed the first delay but the mail 
> server refused. These slides both had images
> to begin with. Is there somewhere I can send these that won't reject 
> them? Thanks.
>
> I will do some more testing in the mean time to see if I uncover
> anything new.
>
> Martin Constantine wrote:
>> Your fix worked! Much better!! Thanks a million!
>>
>>
>> Cameron McCormack wrote:
>>> Hi Martin.
>>>
>>> Martin Constantine:
>>>  
>>>> Any word on this issue? Do you need any clarification/information? 
>>>> Please let me know what I can do to help. Thanks again.
>>>>     
>>>
>>> Sorry, I’ve been a little busy lately.
>>>
>>> I had a look, and yes it seems there’s a bug there.  I wasn’t able to
>>> reproduce it with the test file you gave, though.  I’ve committed a
>>> change: please let me know if it fixes your problem.
>>>
>>> Thanks,
>>>
>>> Cameron
>>>
>>>   
>>
>
>
>



Mime
View raw message