xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Petri" <dele...@googlemail.com>
Subject Problem with mouseover, groups and invisible elements
Date Thu, 04 Sep 2008 16:19:01 GMT
Hi,

I have a problem with the following svg file:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="800px" height="600px" viewBox="0 0 800 600"
enable-background="new 0 0 800 600" xml:space="preserve">
	
	<g>
		<!-- other subelements of the group -->
		<rect x="100" y="100" width="100" height="100" fill="black"></rect>
		<animateTransform attributeName="transform" type="scale" from="1"
to="1.2" fill="freeze" dur="1s" begin="r.mouseover" />
		<animateTransform attributeName="transform" type="scale" from="1.2"
to="1" fill="freeze" dur="1s" begin="r.mouseout" />
		<rect x="100" y="100" width="100" height="100" fill="black" id="r"
opacity="0"></rect>
	</g>
</svg>

Once you point the mouse over the invisible <rect> with id "r" the
group is scaled. But the second (!) time you point the mouse over it,
the scaling falls back to its initial value (1) instantly after the
animation.
Everything works with Adobe SVG viewer but not with Batik.

I demonstrated the problem in a video, too, you can download it here:
http://petroy.naken.net/wordpress/wp-content/uploads/2008/09/batik-problem_1.avi
(AVI, XVid [DivX compatible], about 10 Megabytes)

Regards,
Julian

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message