xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Helder Magalhães" <helder.magalh...@gmail.com>
Subject Java version requirements and upgrading external libraries (was "Re: Batik and Rhino 1.6R7")
Date Fri, 03 Oct 2008 11:19:50 GMT
> But in the meantime I've committed a change to get this to work in Rhino
> 1.6R7. I haven't updated the js.jar from 1.6R5 in the repository yet.

Great! :-) I'll attempt to test the change, possibly whenever file
"js.jar" is also updated.

Related to the upcoming jar file upgrade, I recall Jeremias Maerki
blogging on the results of a pool regarding Java version [1]. In my
working copy I've a few minor changes I'd like to contribute, like
upgrading Ant version to 1.7 (which requires Java 1.5) so I'd like to
ask:
 * Are there any plans to drop Java 1.4 support?
 * Is there a known procedure for upgrading external libraries used
within the project?



> Technically, these functions should return integers that identify the
> timeout/interval, rather than TimerTask objects.

I haven't seen this stated anywhere within the changes nor noticed any
new bug for this (sorry if I missed something). Shouldn't this be
pointed out somewhere (source code comment and/or new bug report) so
it won't get lost? ;-)



Regards,

 Helder Magalhães


[1] http://www.jeremias-maerki.ch/blog/2007/10/15/minimal-java-requirements-for-apache-xml-graphics/
[2] https://issues.apache.org/bugzilla/show_bug.cgi?id=45436

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message