xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From IsmAvatar <cmag...@nni.com>
Subject Re: Cannot build rasterizertask
Date Sun, 23 Nov 2008 23:12:49 GMT
> please consider checking out a fresh copy of the repository [1] (and,
> of course, re-applying the patch already referred [2] afterward).

Ok, now we're closer, and yet back where we started.
Below is exactly what steps I've followed via the console to get to where I'm at.
And then at the bottom is the null pointer exception...

I believe the problem before was when I decided to copy crimson into the lib
directory along with the other 2 ant jars. I need to have ant in a lib
directory in order for eclipse to detect ant.

new console:
svn checkout http://svn.apache.org/repos/asf/xmlgraphics/batik/trunk/
cd trunk\contrib\rasterizertask
edit patch.txt
patch < patch.txt
cd ..\..
build compile

new console:
cd trunk\contrib\rasterizertask
build compile

new console:
cd trunk
build all-jar

new console:
cd trunk\contrib\rasterizertask
build jar
Error: Unknown jar attribute "level"
edit build.xml
<<remove level="9" and save>>
build jar

new console:
cd trunk
build squiggle
Success! (also successfully loaded in my svg)
cp contrib\rasterizertask\build\lib\RasterizerTask.jar lib\RasterizerTask.jar
cp "batik-1.8pre\lib\batik-all.jar" "lib\batik-all.jar"
cp "lib\build\ant-1.6.5.jar" lib
cp "lib\build\ant-launcher-1.6.5.jar" lib
eclipse --clean

I then inform eclipse that the ant location is "trunk",
thus ensuring 1.6.5, since it looks for jars in the lib directory.
I then try to run ant on my build.xml, and it responds in kind:

BUILD FAILED
C:\Java\LateralGM\build.xml:32: java.lang.NullPointerException
	at org.apache.tools.ant.Task.perform(Task.java:373)
	at org.apache.tools.ant.Target.execute(Target.java:341)
	at org.apache.tools.ant.Target.performTasks(Target.java:369)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
	at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)
Caused by: java.lang.NullPointerException
	at org.apache.tools.ant.taskdefs.optional.RasterizerTask.getParserClassName(Unknown Source)
	at org.apache.tools.ant.taskdefs.optional.RasterizerTask.execute(Unknown Source)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
	at org.apache.tools.ant.Task.perform(Task.java:364)
	... 9 more
--- Nested Exception ---
java.lang.NullPointerException
	at org.apache.tools.ant.taskdefs.optional.RasterizerTask.getParserClassName(Unknown Source)
	at org.apache.tools.ant.taskdefs.optional.RasterizerTask.execute(Unknown Source)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
	at org.apache.tools.ant.Task.perform(Task.java:364)
	at org.apache.tools.ant.Target.execute(Target.java:341)
	at org.apache.tools.ant.Target.performTasks(Target.java:369)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
	at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)


line 32:
<rasterize result="image/png"
src="${basedir}/org/lateralgm/main/lgm-logo.svg"
dest="${basedir}/org/lateralgm/main/output.png" />


Of course, before the error there's a whole bunch of other debug info, most of it says
"Could not load class (org.apache.tools.ant.taskdefs.optional.<<something>>) for
<<something>>"

-IsmAvatar


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message