xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Wellner Bou <p...@purecodes.org>
Subject Re: Writing out SVGs setting the 1.1 doctype
Date Thu, 26 Mar 2009 12:37:51 GMT
Hi,

Thanks for your answer. The version attribute is set to 1.1, so in the 
input as in the output document.

Using the transcoder it works better, but the xml declaration has to be 
set manually (string="<?xml...>") and I don't get it to work with the 
right char set. ... And the escaped unicode characters (&x...) are 
replaced automatically, with both methods.

Regards
Paul.

Helder Magalhães wrote:
> Hi Paul,
> 
>> Is there a way to indicate that it should use SVG 1.1 doctype and not the
>> (default?) SVG 1.0 doctype? Or do I really need to use the transcoder for
>> this?
> 
> I'm not familiar enough with the SVG generator to properly answer your
> question but you may try to set the version [1] in your document
> element (to "1.1", in this case) and see if it tricks the generator
> into the desired mode.
> 
> 
>> By the way, the original document I am reading and modifying _does_ have
>> SVG 1.1 doctype.
> 
> Maybe the document doesn't have the version property set? If so, I
> don't know how Batik deals with that. But, then again, I'm just
> guessing... ;-)
> 
> 
> Hope this helps,
>  Helder
> 
> 
> [1] http://www.w3.org/TR/SVG11/struct.html#SVGElementVersionAttribute
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message