xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jonathan wood <jonathanshaww...@gmail.com>
Subject Re: Batik and JUnit
Date Wed, 15 Dec 2010 15:35:49 GMT
Can you share your initialization/document load routine and the handoff to
junit?

On Tue, Dec 14, 2010 at 1:50 PM, shootist <kwilson4813@gmail.com> wrote:

>
> I am attempting to run some unit tests under JFCUnit and JUnit.  I also
> have
> a recorder that uses java robot to perform some tests.
>
> Anytime I modify anything, or even sometimes just starting the code without
> running any actual tests I get svg errors.  Sometimes It's just a null,
> sometimes it tells me there is an invalid attribute (for example, I get an
> error message saying "lll" is not a valid attribute for "pointer-events"),
> and sometimes I get CSS exceptions.
>
> I don't see anyplace in the code where I set any attribute to lll, and I
> don't have any problems running the code.  This only happens within the
> unit
> tests.
>
> I suspect something strange is happening with threading, and the unit tests
> are not waiting for the UpdateManager to complete, but no amount of sleep
> calls seem to help.  Has anyone experienced these problems?
> --
> View this message in context:
> http://batik.2283329.n4.nabble.com/Batik-and-JUnit-tp3087741p3087741.html
> Sent from the Batik - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org
>
>

Mime
View raw message