xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Boegner <daniel.boeg...@synaxon.de>
Subject Empty batik.jar and version identification
Date Fri, 10 Jun 2011 12:40:31 GMT
Hi all,

quick question at first: To subscribe I sent a mail with the subject and
content "subscribe" to the subscription mail adress. Was that the right way?
I did not recieve an verification email and my last registration to an
mailing list is long time ago. ^^

To the topic:
When I down load the current verions batik.zip file the batik.jar file is
empty! There are no packages and no classes included in the batik.jar!

There is only the META-INF directory with three files:
MANIFEST.MF
LICENSE (empty)
NOTICE (empty)



######### begin of manifest of batik 1.7 #########
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.4.2_12-b03 (Sun Microsystems Inc.)
Implementation-Title: Batik
Implementation-Version: 1.7+r608262
Implementation-Vendor: The Apache Software Foundation (http://xmlgraph
 ics.apache.org/batik/)
Build-Id: 20080106-111140-EST (cam [Linux 2.6.22.8 i386, Java 1.4.2_12
 -b03])
Main-Class: org.apache.batik.apps.svgbrowser.Main
Class-Path: lib/batik-ext.jar \           lib/batik-dom.jar \
   lib/batik-css.jar \           lib/batik-svg-dom.jar \           lib
 /batik-gvt.jar \           lib/batik-parser.jar \           lib/batik
 -script.jar \           lib/batik-bridge.jar \           lib/batik-sw
 ing.jar \           lib/batik-anim.jar \           lib/batik-transcod
 er.jar \           lib/batik-gui-util.jar \           lib/batik-awt-u
 til.jar \           lib/batik-codec.jar \           lib/batik-util.ja
 r \           lib/batik-root.jar \           lib/batik-svggen.jar \
          lib/batik-xml.jar \           batik-squiggle.jar \
  batik-rasterizer.jar \           batik-pp.jar \           lib/xerces
 _2_5_0.jar \           lib/xalan-2.6.0.jar \           lib/xml-apis.j
 ar \           lib/xml-apis-ext.jar \           lib/pdf-transcoder.ja
 r \           lib/js.jar

######### end of manifest of batik 1.7 #########


We have already had a batik.jar on our fileserver. There are classes
included in the file. It basically works, but I got Exceptions on some
input. That's why I wanted to try the current version. Actually I don't know
which version this batik.jar is. Here is the content of the manifest file:

######### begin of manifest of the unknown batik version #########
Manifest-Version: 1.0
Created-By: Apache Ant 1.5.1
######### end of manifest of the unknown batik version #########

- Why there are no classes included in the current version of batik.jar? Is
it an mistake / error or did I miss some important documentation or change
in the API?
- How / Where can I download a up-to-date and working batik.jar?
- Maybe it would help to identify the version of the old batik.jar. How do I
do this?

Background: I am using Anty Samy from OWASP to filter out JavaScript from
HTML input and batik is a dependency of anti samy.

Any help would be appreciated. Thanks in advance.


-- 
Daniel Bögner
Bachelor of Science
IT Systemelektroniker
IT - Software Development

Tel. ++ 49 521 / 96 96 268
Fax ++ 49 521 / 96 96 296
mailto: Daniel.Boegner@synaxon.de

SYNAXON AG
Eckendorfer Str. 2-4
D-33609 Bielefeld

Vorstand: Frank Roebers (Vorsitzender), Andreas Wenninger, Mark Schröder
Aufsichtsratsvorsitzender: Dr. Günter Lewald
Handelsregister Bielefeld HRB 36014

Mime
View raw message