xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kislay.2004" <kishore.kis...@zensar.in>
Subject getting error in JPEGTranscoder.transcode()
Date Thu, 28 Jun 2012 11:08:57 GMT

Hi,

I am getting the bwlow error while using JPEGTranscoder.trascode()[I am
using batik 1.7, downloaded yesterday]. This error is occuring at runtime.


java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
I am sure that all the batik jars required are there in my classpath. 

Also, I checked my JRE version using java -version. It says :

java version "1.6.0_13"
Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode)

Let me know if there is some problem with my JVM. What I need to do resolve
this?

Regards,
Kislay

--
View this message in context: http://batik.2283329.n4.nabble.com/getting-error-in-JPEGTranscoder-transcode-tp4655103.html
Sent from the Batik - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message