xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rolf Schumacher <r...@august.de>
Subject projects whith modularized Java
Date Tue, 16 Apr 2019 06:36:40 GMT
I am trying to move my saxon/fop project to Java 11 or 12.

I am using maven and fop 2.4.0-SNAPSHOT, as 2.3 leads to failures.

The SNAPSHOT has less problems, but brings the failure

[WARNING] Can't extract module name from 
batik-script-1.11.0-SNAPSHOT.jar: Provider class 
org.apache.batik.bridge.RhinoInterpreterFactory not in module

similar to the failure requrest

http://mail.openjdk.java.net/pipermail/jigsaw-dev/2017-April/012151.html.

I also tried to find a solution here:

https://stackoverflow.com/questions/54660441/how-to-setup-a-maven-project-using-fop-and-java-11

with improvements but without final success.

Question: do you know of any project using Batik with Java >= version 9? 
How do they cope with automatic modules for and dependencies of Batik?


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message