xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Trotman <mike.trot...@datalucid.com>
Subject Re: Problem when link has "contentid"
Date Fri, 22 Jul 2005 13:26:05 GMT
Are you using the 'url()' function (which may provide url 
encoding/escaping)?

I'm not sure at which stage of the process the error is being thrown
- so don't know if it's a problem in the XSLT stage, or the FO=>PDF stage.

Producing an FO file from your XML (using XSLT),
inspecting the FO file
and then processing the FO file with FOP would identify which part of 
the process causes the problem.

Mike

Fabrizio Caldas wrote:

> Mike,
>
> You're right, my example link is no coherent with the one I use.
> This is a better example f the link I'm using:
> http://www.example.com/fop/test.jsp?pageType=page&contentID=1234
>
> If I switch the pageType and contentID I get a same error but with the 
> pageType:
> The reference to entity "pageType" must end with the ';' delimiter.
>
> So I guess that any link that I have with a & will have this problem.
>
> Fabrizio.
>
>> From: Mike Trotman <mike.trotman@datalucid.com>
>> Reply-To: fop-users@xmlgraphics.apache.org
>> To: fop-users@xmlgraphics.apache.org
>> Subject: Re: Problem when link has "contentid"
>> Date: Fri, 22 Jul 2005 13:48:12 +0100
>>
>> I'm not sure what is making FOP think that contentID is an entity 
>> (can't see any '&'s)
>> but I think you should be using the 'url' function on the link.
>> e.g.:
>> <fo:basic-link color="blue" external-destination="url({@href})">
>>
>> It would also be a good idea to test the XLST part outside FOP - to 
>> see what get's produced in the FO file.
>>
>> Mike
>>
>> Fabrizio Caldas wrote:
>


Message Scanned by ClamAV on datalucid.com


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message