xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samuel Remacle" <srema...@hotmail.com>
Subject Re: FOP embedding problem (NoClassDefFoundError)
Date Tue, 19 Jul 2005 12:16:45 GMT
<html><div style='background-color:'><DIV class=RTE>
<P><BR><BR></P><BR><BR><BR>&gt;From: delbd &lt;delbd@oma.be&gt;<BR>&gt;Reply-To:
fop-users@xmlgraphics.apache.org<BR>&gt;To: fop-users@xmlgraphics.apache.org<BR>&gt;Subject:
Re: FOP embedding problem (NoClassDefFoundError)<BR>&gt;Date: Tue, 19 Jul 2005 12:13:37
+0200<BR>&gt;<BR>&gt;Ok, either i just downloaded fop 0.20.5 src from
http://archive.apache.org/dist/xml/fop/source/<BR>&gt;i checked Driver.java at offending
line (221).<BR>&gt;No way this line could give the error you send us.<BR>&gt;So
either you are using another version, either some tool at compile time<BR>&gt;did
inject code in your .java before compilation occurs.<BR>&gt;Remove all fop related
.class from your environement and hunt for any fop*.jar in your<BR>&gt;system which
my interact at runtime with your environnement. Also try to add a breakpoint in Driver init
code<BR>&gt;to see what debugger has to tell you about 
it.<BR>&gt;<BR>&gt;Your problem really lokks like a mixing up libraries
problem. (aka use an old Driver.class while corresponding<BR>&gt;org.apache.fop.fo.PropertyListMaker.class
is not present anymore). You should check classpath and build directory.<BR>&gt;<BR>&gt;Le
Mardi 19 Juillet 2005 11:59, Samuel Remacle a écrit :<BR>&gt; &gt; &gt;From:
delbd &lt;delbd@oma.be&gt;<BR>&gt; &gt; &gt;Reply-To: fop-users@xmlgraphics.apache.org<BR>&gt;
&gt; &gt;To: fop-users@xmlgraphics.apache.org<BR>&gt; &gt; &gt;Subject:
Re: FOP embedding problem (NoClassDefFoundError)<BR>&gt; &gt; &gt;Date:
Tue, 19 Jul 2005 11:49:26 +0200<BR>&gt; &gt; &gt;<BR>&gt; &gt;
&gt;Hi,<BR>&gt; &gt; &gt;<BR>&gt; &gt; &gt;I downloaded
FOP 0.20.5 and embedded it in a webapplication. works great.<BR>&gt; &gt; &gt;<BR>&gt;
&gt; &gt;First, i see no org.apache.fop.fo.PropertyListMaker (seems replaced by 
org.apache.fop.fo.PropertyListBuilder but not sure)<BR>&gt; &gt; &gt;Then,
i see no ElementMapping$Maker too.<BR>&gt; &gt; &gt;<BR>&gt; &gt;
&gt;According to one of your mail, you are using fop 0.20.5<BR>&gt; &gt;
&gt;<BR>&gt; &gt; &gt;Here i have source of fop 0.20.5 with org.apache.fop.apps.Driver.java<BR>&gt;
&gt; &gt;<BR>&gt; &gt; &gt;at line 221 i see<BR>&gt; &gt;
&gt;<BR>&gt; &gt; &gt;&nbsp;&nbsp;_treeBuilder = new FOTreeBuilder();<BR>&gt;
&gt; &gt;<BR>&gt; &gt; &gt;As you can see, no reference to ElementMapping$Maker
or PropertyListMaker<BR>&gt; &gt; &gt;Looks like you got the wrong sources
or have some old fop libraries/classes somewhere else on your<BR>&gt; &gt; &gt;system
messing up things.<BR>&gt; &gt; &gt;<BR>&gt; &gt; &gt;Le
Mardi 19 Juillet 2005 09:45, Samuel Remacle a écrit :<BR>&gt; &gt; &gt;
&gt; Hello,<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt; &gt;
&gt;<BR>&gt; &gt; &gt; &gt; 
I'm a young programmer and I'd like to embed FOP in my application, but unfortunately I'm
having some problems to do this.<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt; First of all, I tried
to embed FOP using the code given in the sample application ExampleFO2PDF (available with
FOP), but when I tried to test my application, I got the following error:<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; Exception in thread main<BR>&gt; &gt; &gt; &gt;
java.lang.NoClassDefFoundError: org.apache.fop.fo.PropertyListMaker<BR>&gt; &gt;
&gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt;
&gt; &gt; &nbsp;at org.apache.fop.apps.Driver.&lt;init&gt;(Driver.java:221)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; &nbsp;at embedding.ExampleFO2PDF.convertFO2PDF(ExampleFO2PDF.java:80)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; 
&gt; &nbsp;at embedding.ExampleFO2PDF.main(ExampleFO2PDF.java:131)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; I checked the code of my application, but I couldn't find any error
(the code is almost the same as in the sample apllication).<BR>&gt; &gt; &gt;
&gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt; &gt;
&gt; So I decided to test the sample application ExampleFO2PDF, and I got the same error
(I was expecting it).<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt;
&gt; &gt;<BR>&gt; &gt; &gt; &gt; After seaching the web for
a solution, I found (in a CVS commit) the code of the "missing interface" (PropertyListMaker).
So I added this interface to the package and I tested again both applications, and then I
got another error:<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt;
&gt; &gt;<BR>&gt; &gt; &gt; &gt; Exception in thread main<BR>&gt;
&gt; &gt; &gt; java.lang.NoClassDefFoundError: 
org.apache.fop.fo.ElementMapping$Maker<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt; &nbsp;at org.apache.fop.apps.Driver.&lt;init&gt;(Driver.java:221)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; &nbsp;at embedding.ExampleFO2PDF.convertFO2PDF(ExampleFO2PDF.java:80)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; &nbsp;at embedding.ExampleFO2PDF.main(ExampleFO2PDF.java:131)<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; I searched the web once again but I could not find the code of
the "missing class". So I decided to test the FOP application (given with the FOP API). I
tested it with y FO file, and it worked, I got my PDF file without any problem. So I tried
to embed FOP in my application using the code the the FOP application (wich is different from
the code of the sample application), but I got 
the same errors.<BR>&gt; &gt; &gt; &gt;<BR>&gt; &gt; &gt;
&gt;<BR>&gt; &gt; &gt; &gt; The IDE I'm working with is Oracle JDeveloper,
I added the files fop.jar, avalon-framework-cvs-20020806.jar and ant-1.5.1.jar&nbsp;to
the environment, I did not add the Xalan and Batik JARs to the environment because I'm using
more recent versions of Xalan and Batik. I downloaded FOP on the Apache website.<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; I hope that this mail is complete and I would be glad if you could
help me to solve this problem.<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt; Thanks<BR>&gt;
&gt; &gt; &gt;<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt; Samuel REMACLE<BR>&gt; &gt; &gt; &gt;<BR>&gt;
&gt; &gt; &gt;&nbsp;&nbsp;---------------------------------------------------------------------
To unsubscribe, e-mail: 
fop-users-unsubscribe@xmlgraphiccs.apache.org For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org<BR>&gt;
&gt; &gt;<BR>&gt; &gt; &gt;--<BR>&gt; &gt; &gt;David
Delbecq<BR>&gt; &gt; &gt;Royal Meteorological Institute of Belgium<BR>&gt;
&gt; &gt;<BR>&gt; &gt; &gt;-<BR>&gt; &gt; &gt;Is
there life after /sbin/halt -p?<BR>&gt; &gt; &gt;<BR>&gt; &gt;
&gt;---------------------------------------------------------------------<BR>&gt;
&gt; &gt;To unsubscribe, e-mail: fop-users-unsubscribe@xmllgraphics.apache.org<BR>&gt;
&gt; &gt;For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org<BR>&gt;
&gt; &gt;<BR>&gt; &gt; Hi,<BR>&gt; &gt; &nbsp;<BR>&gt;
&gt; Yes, I also looked for these classes and I could not find them, and I also looked
in the Driver class code.<BR>&gt; &gt; &nbsp;<BR>&gt; &gt;
I don't know how I could have the wrong sources or binaries because I 
downloaded them on the Apache website, and I'm sure I don't have another version of FOP on
my system because all I installed on it (related with Java) is Oracle JDeveloper 10g and FOP
doesn't come with this program...<BR>&gt; &gt; &nbsp;<BR>&gt;
&gt; Sam<BR>&gt; &gt;&nbsp;&nbsp;---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org For additional commands,
e-mail: fop-users-help@xmlgraphics.apache.org<BR>&gt;<BR>&gt;--<BR>&gt;David
Delbecq<BR>&gt;Royal Meteorological Institute of Belgium<BR>&gt;<BR>&gt;-<BR>&gt;Is
there life after /sbin/halt -p?<BR>&gt;<BR>&gt;---------------------------------------------------------------------<BR>&gt;To
unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org<BR>&gt;For additional
commands, e-mail: fop-users-help@xmlgraphics.apache.org<BR>&gt;<BR></DIV>
<DIV class=RTE>The goods news is that I found another fop.jar file on my system, I erased
it as well as all the references to it. The bad news is that I tested my application once
agin, and I stil have the same errors, moreover the breakpoint does not give more information
about the error. It's a rude trial for my nerves :(</DIV>
<DIV class=RTE>&nbsp;</DIV>
<DIV class=RTE>Samuel</DIV></div></html>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message