xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sai N <snagb...@gmail.com>
Subject Re: International Fonts - Problem with print
Date Mon, 21 Nov 2005 20:13:17 GMT
I tried something the other day and it worked... I removed the tags
representing italic and bold..
 <font metrics-file="C:\projects\fop-0.20.5\fonts\arialuni.xml"
kerning="yes"
embed-file="C:\WINNT\Fonts\arialuni.ttf">
<font-triplet name="arialuni" style="normal" weight="normal"/>
</font>
<font metrics-file="C:\projects\fop-0.20.5\fonts\batang.xml" kerning="yes"
embed-file="C:\WINNT\Fonts\batang.ttf">
<font-triplet name="batang" style="normal" weight="normal"/>
</font>
 But now I am unable to see bold and italic in my rendered documents.. I
guess I have to figure out if there is a different file for italic and bold
part of these fonts ?
 To you point.. I am using JDK 1.4.2, and I have tried using 1.5 also... in
both cases it gives me the same outcome..
 Thanks,
 Sai

 On 11/21/05, Chris Bowditch <bowditch_chris@hotmail.com> wrote:
>
> Sai N wrote:
>
> > Hello,
> >
> > I am trying to use FOP to print certain documents (in FO) written in
> > some International Languages (Japaneese, Korean, Chinese etc). For some
> > reason the characters are printed at an angle, it looks like everything
> > is in italic. Even the english characters in the document behave in the
> > same way. If I try to create the PDF from the same FO, it works fine and
> > looks great. I have tried using different fonts (Arial Unicode, MS
> > Mincho, Batang) and this happens with everything
>
> The PrintRenderer uses Java AWT Fonts, so the problem is likely caused
> by your JDK. What JDK version and OS are you running on?
>
> Chris
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>
>

Mime
View raw message