xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Brown <Daniel.Br...@binarytree.com>
Subject Saxon8
Date Fri, 11 Nov 2005 16:25:43 GMT
I have tried to implement Saxon8.6 in place of Xalan but am getting 
errors. Are there other libraries I require?

Regards,
Daniel




JBryant@s-s-t.com 
11/11/2005 10:36 AM
Please respond to
fop-users@xmlgraphics.apache.org


To
fop-users@xmlgraphics.apache.org
cc

Subject
Re: Large PDF - Performance






> In this respect, it may prove worthwhile to track down whether
> this difference is really caused by the XSLT processor itself,
> or merely by the fact that Saxon comes bundled with its own
> XML parser (AElfred).

>From the Aelfred web site on Sourceforge:

"Saxon versions from 7.2 onwards no longer include a built-in XML parser. 
This decision was taken because Saxon is now dependent on JDK 1.4, which 
includes its own XML parser, and therefore the original reason for 
bundling a parser with Saxon has disappeared."

That listing is a bit out of date, as the last couple versions (8.5 and 
8.6) of Saxon use the 1.5 JDK.

So, versions 7 & 8 of Saxon (which provide access to XSLT 2.0) use 
Crimson. Version 6.x uses Aelfred. I believe the OP mentioned using Saxon 
8, so the parser in question is Crimson.

FWIW

Jay Bryant
Bryant Communication Services
(presently consulting at Synergistic Solution Technologies)

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org



Mime
View raw message