xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: pagination problem errata corrige
Date Fri, 03 Feb 2006 17:06:48 GMT
Ok, so you DON'T have the same problem as Giovanni. Giovanni uses FOP
0.90 or 0.91 to create RTF which is something entirely different from
what you do. You didn't say that you're using 0.20.5. I had to find out
the hard way when I ran your FO file through FOP 0.91 and it failed due
to malformed XSL-FO. Furthermore, there are entity references in the
test file that are not declared in the file. That's also an excellent
way to waste my time.

I can't say it enough: People, ALWAYS state the FOP version you're using!!!
Otherwise, one day I might stop responding to support requests that don't
contain the most basic info.

I'm sorry if I'm out of line here, but I'm taking a lot of my free time
to answer questions on this list. It probably doesn't help, either, that
I'm suffering from a head-ache at the moment. Grmbl, grmbl...

Okay, my wrath is vented. QUI Meng, it's quite possible that you hit a
bug in 0.20.5. I suggest you try the latest beta release of FOP instead,
because we don't fix any bugs anymore for the old 0.20.5 release. You
will need to bring your XSL-FO code in line with the specification,
though, since FOP 0.91beta is much more strict about the rules.

On 03.02.2006 12:03:32 QIU Meng wrote:
> Yes, you are right. 
>    
>   I tried to reproduce this problem and I attach 2 files for you, one is test file (the
fop code )and another is page pdf.
>    
>   Best Regards
> 
> 
> Jeremias Maerki <dev@jeremias-maerki.ch> a écrit :
>   As I already told Giovanni: no test file, no help possible. I can't
> reproduce the problem.
> 
> On 30.01.2006 17:06:32 QIU Meng wrote:
> > Hi all
> > 
> > I have the same problem, I think that it is a fop bug. when we change a little the
size between 2 lines, the white page will disappear. You can test it.
> > 
> > Best Regards
> > 
> > "gdilem@libero.it" a écrit :
> > Hi all
> > I attach a rtf rendered with fop 0.9.
> > I got a useless white page.
> > any idea how to fixing the number of pages?
> > 
> > ps: I wrote a similar mail but the attachment is wrong!! sorry
> 
> 
> Jeremias Maerki


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message