xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Problem using svg image on both fop.0.20 and fop.0.92beta
Date Fri, 05 May 2006 20:03:58 GMT
Right, the Batik version shipped with FOP 0.20.5 seems to have issues
with data URLs. If you search for "RFC 2397" on this list, you'll find a
generic solution that may even help the older Batik version to process
the data URLs but I didn't check that. At any rate, you'd be able to use
data URLs in external-graphic elements.

The problem with FOP 0.92beta is a known one. I promise to document it
prominently tomorrow. Please see here:
http://www.nabble.com/fop-trunk-svg-problems-t1177182.html
http://www.nabble.com/REGRESSION%3A-embedded-SVG-support-in-0.92beta-compared-to-0.91beta-t1531627.html

The short version of the above:
Make sure you've got the latest version of Xalan-J and Xerces-J
installed in your environment. Earlier Xalan-J versions and the latest
SAXON version all have a bug that causes this problem.

On 05.05.2006 17:12:53 Arturo Perez wrote:
> Hi all,
> 
> I'm having problems with graphics in fop.0.20.5 (my production site)
> and fop.0.92.beta (my soon-to-be site).  The PDF ends up with no image in
> both versions.  I think the problem with 0.20.5 is that it doesn't
> support data URLs.  The .fo fragment looks like this:
> 
> <fo:instream-foreign-object>
> <svg:svg xmlns:svg="http://www.w3.org/2000/svg" width="390" height="186">
> <svg:title>Figure 1. XYZ </svg:title>
> <svg:image xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="data:image/gif;base64,R0lGODlhhgG6ALMPAO3t87K..."
width="390" height="186"/>
> </svg:svg>
> </fo:instream-foreign-object>
> 
> On 0.20 I get no errors but the PDF just has a broken image graphic.
> On 0.92 I get no image whatsoever and the below error.  It's blank where the image should
be and the gap looks to be the correct size. 
> 
> Any help would be greatly appreciated, tia.
> 
> SEVERE: svg graphic could not be built: file:/.../fop-0.92beta/play/:-1
> The attribute "width" of the element <image> is required
> org.apache.batik.bridge.BridgeException: file:/.../fop-0.92beta/play/:-1
> The attribute "width" of the element <image> is required
>         at org.apache.batik.bridge.SVGImageElementBridge.getImageBounds(Unknown Source)
>         at org.apache.batik.bridge.SVGImageElementBridge.createImageGraphicsNode (Unknown
Source)
>         at org.apache.fop.svg.PDFImageElementBridge.superCreateGraphicsNode(PDFImageElementBridge.java:107)
>         at org.apache.fop.svg.PDFImageElementBridge.createImageGraphicsNode(PDFI...



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message