xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: fopFactory setFontBaseURL
Date Sun, 10 Sep 2006 12:40:26 GMT
That's the layout from FOP 0.20.5. You said you're using FOP 0.92beta,
so you have to use that configuration layout. It has changed since
0.20.5. Please take conf/fop.xconf as a template!

See also: http://xmlgraphics.apache.org/fop/0.92/configuration.html

On 10.09.2006 14:34:42 Sam Tsai wrote:
> 
> I put this line:
> 
> fopFactory.setUserConfig(new File("C:/Temp/userconfig.xml"));
> 
> and the config file content is:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> 
> <!-- New document created at Sun Sep 10 05:56:26 CDT 2006 -->
> 
> <configuration>
> 	<font metrics-url="file:///C:/fonts/Arial/Arial.xml" kerning="yes"
> embed-url="file:///C:/fonts/Arial/arial.ttf">
>           <font-triplet name="Arial" style="normal" weight="normal"/>
>           <font-triplet name="ArialMT" style="normal" weight="normal"/>
>     </font>	
> </configuration>
> 
> 
> Sam
> 
> 
> Jeremias Maerki-2 wrote:
> > 
> > Just a hunch:
> > Make sure you call setFontBaseURL() after you specify a userconfig.xml 
> > (if any) and before you create an FOUserAgent or a Fop instance.
> > 
> > On 10.09.2006 13:12:28 Shue-Yen Tsai wrote:
> >> Hi:
> >> 
> >> I embed FOP 0.92 to my program. I can't get the font
> >> to work. I put the 
> >> 
> >> fopFactory.setFontBaseURL("file:///C:/fonts");
> >> 
> >> in the program and put my ttf files, metric files
> >> under the folder c:/fonts. I still got error on
> >> finding fonts. Do I have to create userconfig.xml in
> >> this folder or something else?
> > 
> > 
> > Jeremias Maerki


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message