xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Need help with compiling fop beta for java 1.3 - images not working
Date Fri, 15 Dec 2006 15:16:05 GMT
Copy xalan*.jar, xerces*.jar, serializer*.jar and xml-apis*.jar from
FOP's lib directory into %ANT_HOME%/lib. That should do the trick.

On 15.12.2006 16:02:16 jelka.kosir wrote:
> When I change my JAVA_HOME to jdk 1.3 this is what I get:
> 
> init-avail:
>      [echo] ------------------- Apache FOP 0.92beta [1999-2006] 
> ----------------
> 
>      [echo] See build.properties and build-local.properties for additional 
> build
>  settings
>      [echo] Apache Ant version 1.6.5 compiled on June 2 2005
>      [echo] VM: 1.3.1_19-b03, Sun Microsystems Inc.
>      [echo] JAVA_HOME: C:\Java\jdk1.3.1_19
>      [echo] Jimi Support PRESENT
>      [echo] JAI Support NOT Present
>      [echo] JCE Support NOT Present
>      [echo] JUnit Support NOT Present - Committers are required to have 
> JUnit wo
> rking
>      [echo] XMLUnit Support NOT Present - you can get it from 
> http://xmlunit.sou
> rceforge.net
> 
> init-filters-jdk14:
> 
> init-filters-jdk13:
>      [echo] Use GraphicsConfiguration adapter for JDK 1.3 or earlier.
> 
> init:
> 
> codegen:
>      [echo] Generating the java files from xml resources
>     [mkdir] Created dir: C:\Fop beta\build\gensrc
>     [mkdir] Created dir: C:\Fop 
> beta\build\gensrc\org\apache\fop\fonts\base14
>     [style] Processing C:\Fop beta\src\codegen\encodings.xml to C:\Fop 
> beta\buil
> d\gensrc\org\apache\fop\fonts\CodePointMapping.java
>     [style] Loading stylesheet C:\Fop 
> beta\src\codegen\code-point-mapping.xsl
> 
> BUILD FAILED
> javax.xml.transform.TransformerFactoryConfigurationError: Provider 
> org.apache.xa
> lan.processor.TransformerFactoryImpl not found
> 
> Jeremias Maerki <dev@jeremias-maerki.ch> wrote on 15.12.2006 13:50:41:
> 
> > You need to set the JAVA_HOME environment variable to you actually
> > compile with JDK 1.3.1. You currently compile with a 1.5 class library
> > and compiler as you can see in the first echos from the build. Be sure
> > to do an "ant clear" before you build after switching.
> > 
> 
> > 



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message