xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Phyllis (NIH/NIEHS) [C]" <Brow...@niehs.nih.gov>
Subject RE: Page breaks in RTF
Date Mon, 14 May 2007 17:23:55 GMT
Qasim,
 
I played with mine and determined that "-.07in" causes a page break but "-.05in" does not.
 So it might just be that you have to find that magic number for your situation.  Since I
don't know why it is causing the page break, I don't know how to figure out the magic number
other than trial and error.  Sorry.
 
The only other thing that I notice is I use an empty block that's only there to cause the
page break.  So like
   <fo:block space-before="-.7in" break-before="page"/>        <!-- empty block -->
   <fo:block xsl:use-attribute-sets="nopadding nomargin">    <!-- not sure about
page break here also ? -->
                <fo:table width="100%">
                   ....
               </fo:table>
   </fo:block>
 
Sorry that I can't be more helpful with a real answer.
 
Phyllis
 
 

-----Original Message-----
From: Qasim Rasheed [mailto:qasim.lists@gmail.com]
Sent: Monday, May 14, 2007 11:54 AM
To: fop-users@xmlgraphics.apache.org
Subject: Re: Page breaks in RTF


Phyllis,

Thanks for responding but I still cannot get page breaks to appear for RTF using the kludge.
Here is how my xsl looks like

<fo:block space-before="-.7in" break-before="page" xsl:use-attribute-sets="nopadding nomargin">

            <fo:table width="100%" break-before="page">
                <fo:table-body>
            ...
        </fo:table>
</fo:block>

Any idea what I might be missing? 

Thanks

Qasim


On 5/14/07, Brown, Phyllis (NIH/NIEHS) [C] < BrownP2@niehs.nih.gov> wrote: 

Hi,
 
I recently tried to use FOP 0.93 to produce RTF output and also noticed that the page breaks
didn't work.  I also noticed that a negative space-before on a block caused a page break.
 So I kludged the xsl to cause a page break:
   <fo:block space-before="-.07in" break-before="page"/>
 
We gave up on trying to produce RTF output because of issues with the markers.
 
Good Luck 

Phyllis


-----Original Message-----
From: Qasim Rasheed [mailto: qasim.lists@gmail.com]
Sent: Friday, May 11, 2007 8:52 AM
To: fop-users@xmlgraphics.apache.org
Subject: Page breaks in RTF


Folks,

I am using version 0.93 of FOP in one application. However I have been unable to put page
breaks when using RTF as output format. Is there a way that I can make this work?

Thanks for you help.

Qasim 






-- 
Qasim Rasheed
Certified Advance ColdFusion MX Developer
(IM qasimrasheed AT yahoo, msn or GTalk) 


Mime
View raw message