xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Powanda" <jpowa...@vocera.com>
Subject FW: [docbook-apps] table.of.contents.title.page.recto formatting not working
Date Tue, 08 May 2007 17:58:51 GMT

I thought I'd try the FOP list to see if anyone experienced this.

I moved from DocBook 1.69 XSL to DocBook 1.72 XSl and from FOP 0.25 to
FOP 0.93. The problem I have is the titlepage formatting on the TOC is
dropping out. It worked fine earlier. I don't know what's causing it to
drop out with the newer DocBook XSL and FOP stylesheets.

Here's the template that's not working:

<xsl:template name="table.of.contents.titlepage.recto"> 

        <!-- Insert buckshot graphic at top of TOC title page. -->  
		<fo:block	space-before.optimum="-0.6in"
space-before.minimum="-0.6in" space-before.maximum="-0.6in"
	
space-after.optimum="0.25in" space-after.minimum="0.25in"
space-after.maximum="0.25in">
			<xsl:attribute
name="text-align">right</xsl:attribute>
			<fo:external-graphic>
	    		<xsl:attribute name="src">
	    			<xsl:value-of
select="$chapter.titlepage.image"/>
	    		</xsl:attribute>
				<xsl:attribute
name="height">1.271in</xsl:attribute>
	    		<xsl:attribute
name="width">2.563in</xsl:attribute>    
	    		<xsl:attribute
name="content-width">2.563in</xsl:attribute>		
	  		</fo:external-graphic>  
		 </fo:block> 
		 	                 
  <fo:block xmlns:fo="http://www.w3.org/1999/XSL/Format" 
 
xsl:use-attribute-sets="table.of.contents.titlepage.recto.style" 
                 text-align="left" 
                 margin-left="{$title.margin.left}" 

                 font-size="18pt" 
                 font-family="{$title.fontset}" 
                 font-weight="bold" 
                 start-indent="0in">
                 
         <!-- Put 4-dots graphic before TOC title. -->                 
		<fo:external-graphic>
    		<xsl:attribute name="src">
    			<xsl:value-of select="$title.inline.image"/>
    		</xsl:attribute>
    		<xsl:attribute
name="content-width">0.25in</xsl:attribute>
    		<xsl:attribute name="width">0.25in</xsl:attribute>
    		<xsl:attribute name="height">0.236in</xsl:attribute>
  		</fo:external-graphic>  		 
  		
	  	<xsl:text> </xsl:text>                 
		<xsl:call-template name="gentext">
			<xsl:with-param name="key"
select="'TableofContents'"/>
		</xsl:call-template>
  </fo:block>
</xsl:template>

The component.title template in my customization layer has similar
formatting that's processed correctly. So why isn't this working in the
table of contents?

If anyone has an idea what might be causing this problem, please let me
know.

Regards,
Jeff Powanda


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message