xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hennebert <vincent.henneb...@anyware-tech.com>
Subject Re: Issue with Table spanning multiple pages
Date Thu, 01 Nov 2007 12:11:18 GMT
Hi Kumar,

Puppala, Kumar (LNG-CON) wrote:
> I tested the same failedTable.fo file against fop 0.93 version and it
> works fine. Just an FYI if someone can relate this behavior to the fixes
> added for 0.94.
<snip/>
> 
> I am running into an issue with an fo:table that spans 2 pages. Instead
> of starting the table on the current page, the table is rendered on the
> next page. There seems to be some dependency on the numbers of columns
> used in the table. Once I reduced the number of columns from 6 to 5 for
> this table, it started rendering the table on the current page. Provided
> with this mail are files describing this behavior:

You’re seeing another manifestation of the problem mentioned in a recent 
thread:
http://mail-archives.apache.org/mod_mbox/xmlgraphics-fop-users/200710.mbox/%3c26DB90BE942D3942ABCB5D8B82BD8B9331A9D4@exchange01.trax.aero%3e

Breaks aren’t handled properly when a table contains empty cells. You 
can work around the problem by putting non-breaking spaces in them.

Hopefully I’ll have time to look into it and find a proper fix soon.

Sorry,
Vincent

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message