xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pascal Sancho" <pascal.san...@takoma.fr>
Subject RE: arabic characters not displaying (was: Multipage tables in fop 0.94)
Date Mon, 05 Nov 2007 09:01:10 GMT
Hi,

If the text in your FO file is composed with Latin characters, the text rendered with a font
should be rendered with appropriate glyphes, here Latin glyphes.

Since IqraaMT font renders your text with Arabic glyphes, this means that Latin characters
codes (unicode: blocks 000-23F) are mapped to Arabic glyphes.

This IqraaMT font should be redesigned to map Arabic glyphes to Arabic characters codes (unicode:
block 600-6FF).

Pascal

> -----Message d'origine-----
> De : haritha.peh@wipro.com [mailto:haritha.peh@wipro.com] 
> Envoyé : dimanche 28 octobre 2007 07:43
> 
> Hi Pascal, 
> 
> Thanks for your reply, Let me brief the exact problem iam facing. 
> 
> 
> 1) I have created metric file using Iqraa ttf.  The font name 
> which is mentioned in user-conf.xml is  identified in xsl. 
> When i write the below code in xsl 
> 
>  <fo:block font-family="IqraaMT" font-weight="normal" 
> font-style="normal">Name <fo:block> 
> 
> Arabic text is displayed in PDF . but it is just converting 
> the english character to arabic which is not my requirement. 
> 
> 2) I need to display the arabic text in PDF which is 
> mentioned in  dynamic XML 
> 
> Is that , anything we need to do with  encoding or versioning of xsl. 
> 
> Can you please help me as earliset. 
> 
> Thanks 
> haritha 
> 
> Pascal Sancho wrote:
> > 
> > Hi Harita,
> > Please, send this kind of post to the FOP list, not just to me.
> > And you should indicate the right subject...
> > 
> > I don't know the Iqraaa.ttf font.
> > 
> > You can check this:
> > - does your font file contain the glyphs used in your 
> document (try with
> > an alternate font file),
> > - what character encoding you are using (better is a 
> unicode one, like
> > UTF-8 or UTF-16),
> > - the config file template is the one for the 0.9x serie (typically,
> > config file extension is ".xconf"),
> > - ther is any info related to your problem in logs?
> > 
> > Pascal
> > 
> > 
> > -----Message d'origine-----
> > De : haritha.peh@wipro.com [mailto:haritha.peh@wipro.com] 
> > Envoyé : dimanche 21 octobre 2007 17:06
> > À : Pascal Sancho
> > Objet : RE: Multipage tables in fop 0.94
> > 
> > Hi,
> > 
> > Iam using FOP 0.94, Iam facing problem while displaying 
> arabic text in the
> > pdf template.
> > 
> > I have generated the metric file using Iqraaa ttf.  Changed the
> > bar-conf.xml .Still the arabic characters are displaying as 
> " #####".
> > 
> > Can anybody help to solve the issue.
> > 
> > 
> > Thanks,
> > Haritha
> > 
> > Pascal Sancho wrote:
> >> 
> >> Hi,
> >> 
> >> You should remove the property 
> keep-together.within-column="always" (set
> >> for the fo:block[@id="id2571170"] containing the fo:table)
> >> 
> >> HTH,
> >> 
> >> Pascal
> >> 
> >>> -----Message d'origine-----
> >>> De : Andrew McFarland [mailto:aamcfarland@gmail.com] 
> >>> Envoyé : vendredi 19 octobre 2007 16:38
> >>> 
> >>> Hi,
> >>> 
> >>> I'm using fop 0.94 on Linux, and I'm having problems 
> generating PDF
> >>> documents that contain very long tables.
> >>> 
> >>> I have a DocBook document that I transform to FO using the DocBook
> >>> 1.73.2 stylesheets. When I process this with fop 0.94, 
> the top of the
> >>> table flows off the top of the page. When I process it with fop
> >>> 0.20.5, the table is correctly split across three pages.
> >>> 
> >>> Example documents are on
> >>> 
> >>> http://aamcf.co.uk/tmp/2007-10-19/table.xml
> >>> http://aamcf.co.uk/tmp/2007-10-19/table.fo
> >>> http://aamcf.co.uk/tmp/2007-10-19/table.0.94.pdf
> >>> http://aamcf.co.uk/tmp/2007-10-19/table.0.20.5.pdf
> >>> 
> >>> Should I stick to the older version of fop, or is there 
> >>> another solution?
> >>> 
> >>> Andrew

Mime
View raw message